aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml17
1 files changed, 17 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
new file mode 100644
index 0000000..026d786
--- /dev/null
+++ b/Cargo.toml
@@ -0,0 +1,17 @@
+[package]
+name = "hitomezashi-rs"
+description = "Classic two-colored Hitomezashi stitch pattern generator."
+readme = "README.md"
+version = "1.0.0"
+authors = ["Nicholas Johnson <nick@nicholasjohnson.ch>"]
+edition = "2021"
+repository = "https://git.nicholasjohnson.ch/hitomezashi-rs"
+license = "GPL-3.0-or-later"
+exclude = [
+ "samples/*",
+]
+
+[dependencies]
+clap = { version = "4.5.3", features = ["derive"] }
+colored = "2.1.0"
+rand = "0.8.5"