diff options
author | Tad Fisher <tadfisher@gmail.com> | 2022-02-12 17:51:59 -0800 |
---|---|---|
committer | Tad Fisher <129148+tadfisher@users.noreply.github.com> | 2022-02-12 17:54:50 -0800 |
commit | 951e1263544994d8ef6c512eaed4dba569840532 (patch) | |
tree | fd23230a2ccc54979bec1503789e1c2d3d6d2b0f /flake.nix | |
parent | e0a023df7ebacb241ccd13dfe02a498e7c32cfe6 (diff) | |
download | pass-otp-951e1263544994d8ef6c512eaed4dba569840532.tar.gz pass-otp-951e1263544994d8ef6c512eaed4dba569840532.zip |
flake: Add derivation for pass with local otp build
Diffstat (limited to 'flake.nix')
-rw-r--r-- | flake.nix | 43 |
1 files changed, 4 insertions, 39 deletions
@@ -9,47 +9,12 @@ flake-utils.lib.eachDefaultSystem (system: let pkgs = nixpkgs.legacyPackages.${system}; in { - defaultPackage = with pkgs; stdenv.mkDerivation { - pname = "pass-otp"; - version = "unstable"; - src = ./.; + defaultPackage = self.packages.${system}.pass-otp; - buildInputs = [ oathToolkit ]; + packages = { + pass-otp = pkgs.callPackage ./default.nix { }; - checkInputs = [ - bash - expect - git - gnumake - gnupg - pass - shellcheck - which - ]; - - dontBuild = true; - doCheck = true; - - patchPhase = '' - sed -i -e 's|OATH=\$(which oathtool)|OATH=${oathToolkit}/bin/oathtool|' otp.bash - ''; - - checkPhase = '' - make SHELL=$SHELL check - ''; - - installFlags = [ - "PREFIX=$(out)" - "BASHCOMPDIR=$(out)/share/bash-completions/completions" - ]; - - meta = with lib; { - description = "A pass extension for managing one-time-password (OTP) tokens"; - homepage = "https://github.com/tadfisher/pass-otp"; - license = licenses.gpl3; - maintainers = with maintainers; [ tadfisher ]; - platforms = platforms.unix; - }; + pass-with-otp = pkgs.pass.withExtensions (e: [ self.packages.${system}.pass-otp ]); }; checks.pass-otp = self.defaultPackage.${system}; |