aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix43
1 files changed, 4 insertions, 39 deletions
diff --git a/flake.nix b/flake.nix
index 3fb9ad2..dd8d5c6 100644
--- a/flake.nix
+++ b/flake.nix
@@ -9,47 +9,12 @@
flake-utils.lib.eachDefaultSystem (system:
let pkgs = nixpkgs.legacyPackages.${system}; in
{
- defaultPackage = with pkgs; stdenv.mkDerivation {
- pname = "pass-otp";
- version = "unstable";
- src = ./.;
+ defaultPackage = self.packages.${system}.pass-otp;
- buildInputs = [ oathToolkit ];
+ packages = {
+ pass-otp = pkgs.callPackage ./default.nix { };
- checkInputs = [
- bash
- expect
- git
- gnumake
- gnupg
- pass
- shellcheck
- which
- ];
-
- dontBuild = true;
- doCheck = true;
-
- patchPhase = ''
- sed -i -e 's|OATH=\$(which oathtool)|OATH=${oathToolkit}/bin/oathtool|' otp.bash
- '';
-
- checkPhase = ''
- make SHELL=$SHELL check
- '';
-
- installFlags = [
- "PREFIX=$(out)"
- "BASHCOMPDIR=$(out)/share/bash-completions/completions"
- ];
-
- meta = with lib; {
- description = "A pass extension for managing one-time-password (OTP) tokens";
- homepage = "https://github.com/tadfisher/pass-otp";
- license = licenses.gpl3;
- maintainers = with maintainers; [ tadfisher ];
- platforms = platforms.unix;
- };
+ pass-with-otp = pkgs.pass.withExtensions (e: [ self.packages.${system}.pass-otp ]);
};
checks.pass-otp = self.defaultPackage.${system};